[geeklog-devel] Draft of schema for GL2

Vincent Furia vfuria at gmail.com
Thu Dec 16 14:31:36 EST 2004

> Not sure I agree.  We similar logic in the 1.3.x code with respect to
> the inGroup() method.  If you get rid of the logical name then you are
> also saying to get rid of the inGroup() method all together.  Is that
> what you really want?  Just want to be sure before we run off and remove it.
Yes.  If you look in the geeklog code for calls to SEC_inGroup() it is
really only used for the  Root group.  Most of the other instance
where it is used it is used against a group id variable.  The
remainder I would argue are redundant if we better respected
privileges in 1.3.x.  I'd recommend a "isRoot" function, but I think
"inGroup" is really not needed except when actually administering
group membership.

> No comments at this time.  I was wondering WTF those columns were for.
> Can we come up with a more descriptive name for them in the GL2 schema?
> In the meantime I'll be considering this versus other search tree
> implementations.
Better names for those columns wouldn't hurt, I just couldn't come up
with anything better when I was implementing it in 1.3.x.  I looked
around at other algorithms when I was first looking into improving the
performance of comments and didn't find anything better.  If you do
find something let me know.  This was, by far, the best I found.  The
biggest downside is that I had to lock the table during inserts, but
that is really OBE since we can use transactions.


More information about the geeklog-devel mailing list