[geeklog-devel] Minimum requirements: MySQL

Tony Bibbs tony at tonybibbs.com
Fri Jan 21 14:17:07 EST 2005

Not at all.  Makes perfect sense.


Dirk Haun wrote:

>For the next Geeklog release, I'm going to raise the minimum requirements
>_slightly_ again.
>This time, it's the MySQL version: The new minimum requirement will be
>3.23.2. Currently, we don't specifiy a minimum version and have even
>incorporated changes to support 3.22 in the past.
>As of MySQL 3.23.2 it's possible to have an index on a field that's
>DEFAULT NULL. We take that into account in the inital install, but not in
>upgrades and it's a real hassle to handle that in upgrades.
>I think this is reasonable. MySQL AB have stopped supporting 3.22 long
>ago, and anyone running on something older than 3.23.45 (or thereabouts)
>is vulnerable to various security issues anyway. Not to mention that the
>current version recommended for production use is 4.1.9.
>I'm also going to change the install script such that it aborts the
>install when it encounters PHP versions older than 4.1.0 or MySQL
>versions older than 3.23.2.
>Parallel to that, my goal for Geeklog 1.3.12 is to get rid of the old
>"long" PHP HTTP arrays ($HTTP_GET_VARS, etc.) and only use the "short"
>ones ($_GET). This will help people running PHP 5, where the old-style
>arrays are disabled by default.
>Since some plugins and add-ons may require the "long" arrays, I'm going
>to add a warning to the install script for that case (as suggested by bug
>report #360).
>Does anyone see a problem with any of this?
>bye, Dirk

More information about the geeklog-devel mailing list